Задать вопрос
14 ноября, 08:49

Дан массив а, содержащий 10 элементов, составить программу нахождения произведения всех элементов массива. (Заполнить массив с помощью random).

+4
Ответы (1)
  1. 14 ноября, 10:35
    0
    Var

    a:array [1 ... 10] of integer;

    i:integer;

    pr:int64;

    begin

    pr:=1;

    for i:=1 to 10 do

    begin

    a[i]:=random (50) ;

    write (a[i],' ') ;

    pr:=pr*a[i];

    end;

    writeln;

    writeln ('Произведение = ', pr) ;

    end.
Знаете ответ на вопрос?
Не уверены в ответе?
Правильный ответ на вопрос 👍 «Дан массив а, содержащий 10 элементов, составить программу нахождения произведения всех элементов массива. (Заполнить массив с помощью ...» по предмету 📗 Информатика. Развернутая система поиска нашего сайта обязательно приведёт вас к нужной информации. Как вариант - оцените ответы на похожие вопросы. Но если вдруг и это не помогло - задавайте свой вопрос знающим оппонентам, которые быстро дадут на него ответ!
Искать готовые ответы
Похожие вопросы по информатике
Хотя бы 3-4 задачи! 1) Дан одномерный целочисленный массив размерностью N. Найдите количество элементов, которые кратны 3 (5). 2) Дан одномерный целочисленный массив А, состоящий из N элементов. Найти сумму всех четных элементов массива.
Ответы (1)
дан массив из семи элементов написать программу подсчитывающую среднее второго и предпоследнего элементов массива дан целочисленный массив из 10 элементов написать программу находящую сумму элементов массива красных 3 ил 5 дан целочисленный массив
Ответы (1)
Помогите решить задачи на паскаль. 1) Дан массив случайных чисел (количество элементов вводите с клавиатуры). Найти произведение всех элементов массива. 2) Дан массив случайных чисел (количество элементов вводите с клавиатуры).
Ответы (1)
Дана программа нахождения суммы всех элементов массива. Изменить программу таким образом, чтобы: a) массив состоял из 15 элементов вещественного типа; b) значения элементов массива должны меняться в интервале от 0 до 5;
Ответы (1)
1. Возвести в квадрат все элементы массива A. Размер массива и значения элементов массива - произвольные. 2. Увеличить на 4 все элементы в первой половине массива A (считать, что в массиве чётное число элементов).
Ответы (1)