Задать вопрос
23 февраля, 18:18

Составьте программу в Паскаль с помощью while. У Малыша К банок варенья. В первый день Карлсон съел одну банку, в каждый последующий день съедая в 1,5 раза больше, чем в предыдущий. Через сколько дней варенье кончится?

+4
Ответы (1)
  1. 23 февраля, 18:51
    0
    Var K, den, s_el: real;

    Begin

    Writeln ('Введите K банок') ;

    readln (K) ;

    s_el:=1;

    K:=K - s_el;

    den:=1;

    While (K>0) do

    Begin

    s_el: = s_el * 1.5;

    K:=K - s_el;

    den:=den+1;

    end;

    Writeln ('Варенье кончится через ', den, ' дней') ;

    readln () ;

    end.
Знаете ответ на вопрос?
Не уверены в ответе?
Правильный ответ на вопрос 👍 «Составьте программу в Паскаль с помощью while. У Малыша К банок варенья. В первый день Карлсон съел одну банку, в каждый последующий день ...» по предмету 📗 Информатика. Развернутая система поиска нашего сайта обязательно приведёт вас к нужной информации. Как вариант - оцените ответы на похожие вопросы. Но если вдруг и это не помогло - задавайте свой вопрос знающим оппонентам, которые быстро дадут на него ответ!
Искать готовые ответы