Задать вопрос
4 марта, 02:31

Написать программу, которая вставляет число K в заданную возрастающую последовательность таким образом, что в результате полученная последовательность также остается полностью возрастающей.

(Язык программирования - Паскаль) - Писать адекватно

+4
Ответы (1)
  1. 4 марта, 03:14
    0
    Var a:array[1 ... 11] of integer;

    i, k, t:integer;

    begin

    for i:=1 to 10 do

    read (a[i]) ;

    read (k) ;

    for t:=1 to 11 do

    if a[t]>k then break;

    for i:=11 downto t+1 do

    a[i]:=a[i-1];

    a[t]:=k;

    for i:=1 to 11 do

    write (a[i],' ') ;

    end.
Знаете ответ на вопрос?
Не уверены в ответе?
Правильный ответ на вопрос 👍 «Написать программу, которая вставляет число K в заданную возрастающую последовательность таким образом, что в результате полученная ...» по предмету 📗 Информатика. Развернутая система поиска нашего сайта обязательно приведёт вас к нужной информации. Как вариант - оцените ответы на похожие вопросы. Но если вдруг и это не помогло - задавайте свой вопрос знающим оппонентам, которые быстро дадут на него ответ!
Искать готовые ответы
Похожие вопросы по информатике
Отметьте истинные утверждения о языках программирования: 1). Языки программирования бывают универсальными и специализированными. 2). Язык программирования Python - универсальный язык программирования. 3).
Ответы (1)
Ввести слово и число раз (Ввод; паскаль, 3). Вывести это слово так: паскаль паскаль паскаль паскаль паскаль паскаль
Ответы (1)
На паскаль ABC 1). составте программу которая удаляет первое слово текста 2) составте программу которая вставляет одно слово в текст после первого пробела
Ответы (1)
6) Ребята в классе из 30 человек изучают языки программирования, и каждый знает зотя бы один язык. Паскаль изучили 20 человек, Python 15 человек, C + + 10 человек. Паскаль и Python знают 5 человек, Паскаль и C + + 8 человек, Python и С + + 5 человек.
Ответы (1)
На каком языке программирования можно писать на егэ? и во всех ли заданиях на этом (этих) языка я слышал что можно бейсик паскаль си питон Но в школе проходят не паскаль а Паскаль АБС можно ли по этому правилу сдавать егэ на С + + или С#?
Ответы (1)