Задать вопрос
22 февраля, 03:02

Pascal

Составить программу, которая считывает целое число. Если оно четное и положительное, увеличить его в два раза, в противном случае увеличить в 10 раз

+5
Ответы (1)
  1. 22 февраля, 04:48
    0
    Program p1;

    var x: integer;

    begin

    writeln ('введите число') ;

    readln (x) ;

    if (x mod 2 = 0) and (x > 0) then

    x:=x*2

    else

    x:=x*10;

    writeln (x) ;

    end.
Знаете ответ на вопрос?
Не уверены в ответе?
Правильный ответ на вопрос 👍 «Pascal Составить программу, которая считывает целое число. Если оно четное и положительное, увеличить его в два раза, в противном случае ...» по предмету 📗 Информатика. Развернутая система поиска нашего сайта обязательно приведёт вас к нужной информации. Как вариант - оцените ответы на похожие вопросы. Но если вдруг и это не помогло - задавайте свой вопрос знающим оппонентам, которые быстро дадут на него ответ!
Искать готовые ответы