Задать вопрос
5 марта, 18:20

Напишите программу в синтаксисе Free Pascal или Turbo Pascal, которая вычисляет выражение, состоящее из чисел и знаков (допускаются только знаки "+" или "-", количество чисел и знаков не ограничено). Выражение вводится как символьная строка, все числа целые.

ввод:

12+42-44-12-13+1-23

вывод: - 37

ввод:

12-53-2+23+0-25

вывод - 45

+5
Ответы (1)
  1. 5 марта, 18:44
    0
    Var

    S, chislo: string;

    i, A, B, C, E: integer;

    Begin

    B : = 0;

    WriteLn ('Введите выражение: ') ;

    ReadLn (S) ;

    i : = S. length;

    While (i > 0) do

    begin

    Case S[i] of

    '+':

    begin

    val (chislo, A, E) ;

    B : = B + A;

    chislo : = '';

    end;

    '-':

    begin

    val (chislo, A, E) ;

    B : = B - A;

    chislo : = '';

    end;

    else

    chislo : = S[i] + chislo;

    End;

    i : = i - 1;

    end;

    if (chislo '') then

    begin

    val (chislo, A, E) ;

    B : = B + A;

    end;

    WriteLn (B) ;

    End.
Знаете ответ на вопрос?
Не уверены в ответе?
Правильный ответ на вопрос 👍 «Напишите программу в синтаксисе Free Pascal или Turbo Pascal, которая вычисляет выражение, состоящее из чисел и знаков (допускаются только ...» по предмету 📗 Информатика. Развернутая система поиска нашего сайта обязательно приведёт вас к нужной информации. Как вариант - оцените ответы на похожие вопросы. Но если вдруг и это не помогло - задавайте свой вопрос знающим оппонентам, которые быстро дадут на него ответ!
Искать готовые ответы