Задать вопрос
15 марта, 17:33

Составить программу на языке Паскаль.

а) Вычислить среднее арифметическое элементов массива А (20) равных за данному числу а.

б) Вычислить произведение модулей элементов массива А (20).

+3
Ответы (1)
  1. 15 марта, 17:46
    0
    Первая задача:

    var

    i, c, sum: shortint;

    sr: real;

    m: array[1 ... 20] of shortint;

    begin

    sum : = 0;

    readln (c) ;

    for i : = 1 to c do

    begin

    readln (m[i]) ;

    sum : = sum + m[i];

    end;

    sr : = sum / c;

    sr : = round (sr * 100) / 100; / / если округлять не нужно, удали эту строчку

    writeln ('Среднее арифметическое: ', sr) ;

    end.

    Вторая задача:

    var

    i, c: shortint;

    p: integer;

    m: array[1 ... 20] of shortint;

    begin

    p : = 1;

    readln (c) ;

    for i : = 1 to c do readln (m[i]) ;

    for i : = 1 to c do p : = abs (p * (m[i])) ;

    writeln ('Произведение всех модулей массива: ', p)

    end.
Знаете ответ на вопрос?
Не уверены в ответе?
Правильный ответ на вопрос 👍 «Составить программу на языке Паскаль. а) Вычислить среднее арифметическое элементов массива А (20) равных за данному числу а. б) Вычислить ...» по предмету 📗 Информатика. Развернутая система поиска нашего сайта обязательно приведёт вас к нужной информации. Как вариант - оцените ответы на похожие вопросы. Но если вдруг и это не помогло - задавайте свой вопрос знающим оппонентам, которые быстро дадут на него ответ!
Искать готовые ответы