Задать вопрос
7 мая, 00:13

Напишите на паскале. Задание: Написать программу, определяющую, можно ли треугольник со сторонами a, b, c поместить внутри круга радиусом

R

+5
Ответы (1)
  1. 7 мая, 03:32
    0
    Var a, b, c, r, s, p: real;

    begin

    write ('длины сторон треугольника a, b, c через пробел: ') ;

    readln (a, b, c) ;

    write ('радиус круга r: ') ; readln (r) ;

    p: = (a+b+c) / 2;

    s:=sqrt (p * (p-a) * (p-b) * (p-c)) ;

    if r> = (a*b*c) / (4*s) then writeln ('можно поместить')

    else writeln ('нельзя поместить') ;

    end.

    длины сторон треугольника a, b, c через пробел: 3 4 5

    радиус круга r: 2.49

    нельзя поместить

    длины сторон треугольника a, b, c через пробел: 3 4 5

    радиус круга r: 2.5

    можно поместить
Знаете ответ на вопрос?
Не уверены в ответе?
Правильный ответ на вопрос 👍 «Напишите на паскале. Задание: Написать программу, определяющую, можно ли треугольник со сторонами a, b, c поместить внутри круга радиусом R ...» по предмету 📗 Информатика. Развернутая система поиска нашего сайта обязательно приведёт вас к нужной информации. Как вариант - оцените ответы на похожие вопросы. Но если вдруг и это не помогло - задавайте свой вопрос знающим оппонентам, которые быстро дадут на него ответ!
Искать готовые ответы