Задать вопрос
20 сентября, 13:10

Составить программу на Паскаль

Из массива Р, содержащего 10 элементов, сформировать массив Н по правилу:

Н (к) = I/P (к), (к - чётные), Н (к) = Р (к) + к, (к - нечётные)

В массиве, содержащем 10 элементов, нечётным элементам присвоить значения квадратов их индек сов.

В массиве, содержащем 10 элементов, напечатать индекс последнего из элементов, равных 0.

+1
Ответы (1)
  1. 20 сентября, 16:59
    0
    {Из массива Р, содержащего 10 элементов, сформировать массив Н по правилу: Н (к) = I/P (к), (к - чётные), Н (к) = Р (к) + к, (к - нечётные) В массиве, содержащем 10 элементов, нечётным элементам присвоить значения квадратов их индексов. В массиве, содержащем 10 элементов, напечатать индекс последнего из элементов, равных 0.}var P:array[1 ... 10] of integer; H:array[1 ... 10] of real; i:integer; index1, index2:integer;

    begin

    writeln ('Введите элементы массива P: ') ; for i:=1 to 10 do begin readln (P[i]) ; end; writeln; writeln ('Массив P: ') ; for i:=1 to 10 do begin write (' '+P[i]+' ') ; end;

    writeln; writeln ('Массив H: ') ; for i:=1 to 10 do begin if (i mod 2 = 0) then begin H[i]:=1/P[i]; end; if (i mod 2 0) then begin H[i]:=P[i]+i; end; end; for i:=1 to 10 do begin write (' '+H[i]+' ') ; end; writeln; writeln; writeln ('Нечётным элементам присваиваем значения квадратов их индексов') ; for i:=1 to 10 do begin if (i mod 2 0) then P[i]:=i*i; end; for i:=1 to 10 do begin if (i mod 2 0) then H[i]:=i*i; end; writeln ('Массив P: ') ; for i:=1 to 10 do begin write (' '+P[i]+' ') ; end;

    writeln; writeln ('Массив H: ') ; for i:=1 to 10 do begin write (' '+H[i]+' ') ; end; writeln; writeln; writeln ('Напечатать индекс последнего из элементов, равных 0') ; for i:=1 to 10 do begin if (P[i] = 0) then index1:=i; end; writeln; writeln ('Индекс для массива P: '+index1) ; for i:=1 to 10 do begin if (H[i] = 0) then index2:=i; end; writeln; writeln ('Индекс для массива H: '+index2) ; end.
Знаете ответ на вопрос?
Не уверены в ответе?
Правильный ответ на вопрос 👍 «Составить программу на Паскаль Из массива Р, содержащего 10 элементов, сформировать массив Н по правилу: Н (к) = I/P (к), (к - чётные), Н ...» по предмету 📗 Информатика. Развернутая система поиска нашего сайта обязательно приведёт вас к нужной информации. Как вариант - оцените ответы на похожие вопросы. Но если вдруг и это не помогло - задавайте свой вопрос знающим оппонентам, которые быстро дадут на него ответ!
Искать готовые ответы