Задать вопрос
20 декабря, 02:15

Необходимо написать программу, которая вычислит сумму 1+1/3+1/3^2 + ... + 1/3^n на языке C++, используя цикл for

+4
Ответы (1)
  1. 20 декабря, 05:12
    0
    Microsoft VS 2017 (C++)

    #include

    using namespace std;

    double find (int n) {

    double rez = 1.;

    for (int i = 1; i < = n; i++) {

    rez + = 1 / pow (3, i) ;

    }

    return rez;

    }

    int main () {

    int n; cin >> n;

    cout << find (n) << endl;

    system ("pause") ; / / если не компилируется, поменяй эту строку / / на getchar ()

    return 0;

    }
Знаете ответ на вопрос?
Не уверены в ответе?
Правильный ответ на вопрос 👍 «Необходимо написать программу, которая вычислит сумму 1+1/3+1/3^2 + ... + 1/3^n на языке C++, используя цикл for ...» по предмету 📗 Информатика. Развернутая система поиска нашего сайта обязательно приведёт вас к нужной информации. Как вариант - оцените ответы на похожие вопросы. Но если вдруг и это не помогло - задавайте свой вопрос знающим оппонентам, которые быстро дадут на него ответ!
Искать готовые ответы