Задать вопрос
10 февраля, 00:33

Дан одномерный массив целых чисел размерностью 20.

Определите количество положительных групп в этом массиве.

(группа это последовательность состоящая из 2-х и более положительных чисел находящихся рядом.)

+5
Ответы (1)
  1. 10 февраля, 02:58
    0
    Const N=20;

    Var m:array[1 ... N]of real;

    i, group:byte;

    fl: boolean;

    Begin

    for i : = 1 to 20 do

    begin

    m[i] : = random (20) - 10;

    writeln ('[', i, '] = > ', m[i]) ;

    end;

    group:=0;

    fl:=false;

    for i:=1 to N-1 do

    If (m[i]>0) and (m[i+1]>0) Then

    fl:=true

    else

    if fl and (m[i+1]<=0) then

    begin

    inc (group) ;

    fl:=false

    end;

    if (fl) then inc (group) ;

    writeln (group) ;

    End.
Знаете ответ на вопрос?
Не уверены в ответе?
Правильный ответ на вопрос 👍 «Дан одномерный массив целых чисел размерностью 20. Определите количество положительных групп в этом массиве. (группа это последовательность ...» по предмету 📗 Информатика. Развернутая система поиска нашего сайта обязательно приведёт вас к нужной информации. Как вариант - оцените ответы на похожие вопросы. Но если вдруг и это не помогло - задавайте свой вопрос знающим оппонентам, которые быстро дадут на него ответ!
Искать готовые ответы