Задать вопрос
21 октября, 20:04

Задача "Дележ яблок" Условие n школьников делят k яблок поровну, неделящийся остаток остается в корзинке. Сколько яблок достанется каждому школьнику? Сколько яблок останется в корзинке? Программа получает на вход числа n и k и должна вывести искомое количество яблок (два числа).

+3
Ответы (1)
  1. 21 октября, 20:26
    0
    Var

    n, k:integer;

    begin

    Write ('Введите количество школьников и количество яблок: ') ;

    Read (n, k) ;

    Writeln ('Каждому школьнику достанется яблок: ', k div n) ;

    Writeln ('Останется в корзине яблок: ', k mod n)

    end.

    Пример

    Введите количество школьников и количество яблок: 19 50

    Каждому школьнику достанется яблок: 2

    Останется в корзине яблок: 12
Знаете ответ на вопрос?
Не уверены в ответе?
Правильный ответ на вопрос 👍 «Задача "Дележ яблок" Условие n школьников делят k яблок поровну, неделящийся остаток остается в корзинке. Сколько яблок достанется каждому ...» по предмету 📗 Информатика. Развернутая система поиска нашего сайта обязательно приведёт вас к нужной информации. Как вариант - оцените ответы на похожие вопросы. Но если вдруг и это не помогло - задавайте свой вопрос знающим оппонентам, которые быстро дадут на него ответ!
Искать готовые ответы
Похожие вопросы по информатике
N школьников делят k яблок поровну, неделящийся остаток остается в корзинке. Сколько яблок достанется каждому школьнику? Сколько яблок останется в корзинке? Программа получает на вход числа n и k и должна вывести искомое количество яблок (два числа).
Ответы (1)
N школьников делят K яблок поровну, неделящийся остаток остается в корзинке. Сколько яблок достанется каждому школьнику? Входные данные Программа получает на вход числа N и K. Выходные данные Программа должна вывести искомое количество яблок.
Ответы (1)
Из N школьников делят K и персиков поровну, неделящийся остаток остается в корзинке. Сколько персиков останется в корзинке? Программа получает на вход числа N И и И K и должна вывести искомое количество персиков. Язык C.
Ответы (1)
1. Напишите программу, которая в последовательности натуральных чисел определяет количество чисел, кратных 4. Программа получает на вход количество чисел в последовательности, а затем сами числа. В последовательности всегда имеется число, кратное 4.
Ответы (1)
1) Напишите программу которая в последствии натуральных чисел определяет, есть ли в последовательности нечетные числа не оканчивающихся на 1. Вход: программа получает на выход кол-во чисел, а затем сами числа.
Ответы (2)