Задать вопрос
11 февраля, 21:25

Надо написать программу

Вычислите N! ("эн-факториал") - произведение всех натуральных чисел от 1 до N (N!=1∙2∙3∙ ...∙ N).

Входные данные

Вводится единственное число N - натуральное, не превосходит 12.

Выходные данные

Выведите полученное значение N!

Примеры

входные данные

2

выходные данные

2

входные данные

3

выходные данные

6 (На Паскале) Буду благодарен

+5
Ответы (2)
  1. 11 февраля, 22:12
    -1
    Var b, i, k, n: int64;

    begin

    readln (n) ;

    b:=1;

    for i : = 1 to n do

    b:=b*i;

    writeln (b) ;

    end.

    Входные данные подставлять в переменную n
  2. 12 февраля, 00:15
    +1
    Program fact;

    var

    n, f, i: integer;

    begin

    f : = 1;

    readln (n) ;

    for i : = 2 to n do

    f : = f * i;

    writeln (f) ;

    end.
Знаете ответ на вопрос?
Не уверены в ответе?
Правильный ответ на вопрос 👍 «Надо написать программу Вычислите N! ("эн-факториал") - произведение всех натуральных чисел от 1 до N (N!=1∙2∙3∙ ...∙ N). Входные данные ...» по предмету 📗 Информатика. Развернутая система поиска нашего сайта обязательно приведёт вас к нужной информации. Как вариант - оцените ответы на похожие вопросы. Но если вдруг и это не помогло - задавайте свой вопрос знающим оппонентам, которые быстро дадут на него ответ!
Искать готовые ответы