Задать вопрос
15 ноября, 03:40

Решить в паскале:

дано двузначное число,

определить:

а) кратно ли 3 сумма его цифр;

б) кратно ли сумма его цифр числу a

+3
Ответы (1)
  1. 15 ноября, 04:37
    0
    Var a, c: integer;

    begin

    read (c, a) ;

    if ((c mod 10 + c div 10) mod 3 = 0)

    writeln ('кратно 3') ;

    else

    writeln ('не кратно 3') ;

    if ((c mod 10 + c div 10) mod a = 0)

    writeln ('кратно ', a) ;

    else

    writeln ('не кратно ', a) ;

    end.
Знаете ответ на вопрос?
Не уверены в ответе?
Правильный ответ на вопрос 👍 «Решить в паскале: дано двузначное число, определить: а) кратно ли 3 сумма его цифр; б) кратно ли сумма его цифр числу a ...» по предмету 📗 Информатика. Развернутая система поиска нашего сайта обязательно приведёт вас к нужной информации. Как вариант - оцените ответы на похожие вопросы. Но если вдруг и это не помогло - задавайте свой вопрос знающим оппонентам, которые быстро дадут на него ответ!
Искать готовые ответы
Похожие вопросы по информатике
1. Дано двузначное число. Определить: a. какая из его цифр больше, первая или вторая; b. одинаковы ли его цифры. 2. Дано двухзначное число. Определить, равен ли квадрат этого числа учетверённой сумме кубов его цифр.
Ответы (1)
Напишите программу на паскале, которая 1) сначала определит по введенному двузначному числу цифру десятков и цифру единиц. 2.1) Если цифра десятков меньше цифры единиц, то программа выведет двузначное число, состоящее из. цифр единиц.
Ответы (1)
Дано натуральное число: определить а) количество цифр в нем б) сумму его цифр в) произведение его цифр г) среднее арифметическое его цифр д) сумму квадратов его цифр е) сумму кубов его цифр ж) его первую цифру з) сумму его первой и последней цифр
Ответы (1)
Задача на Паскале. Дано число, если оно кратно 3 (трем) - увеличить его на 5, если кратно 2 (двум) - увеличить в 4 раза, если не кратно - увеличить на 1. * Использовать функцию "остаток от деления равен нулю".
Ответы (1)
6.22) Дано натуральное число. Определить: а) количество цифр 3 в нем; б) сумму его цифр, больших пяти; в) произведение его цифр, больших семи; 6.26) Дано натуральное число. а) определить его максимальную цифру. б) определить его минимальную цифру.
Ответы (1)