Задать вопрос
20 октября, 04:57

Напишите программу для решения задачи

Определить является ли данное число n чётным двухзначным числом

+2
Ответы (2)
  1. 20 октября, 05:24
    0
    Var

    n: integer;

    begin

    readln (n) ;

    writeln ((n mod 2 = 0) and (n div 10 > 0) and (n div 100 = 0)) ;

    end.
  2. 20 октября, 07:51
    0
    Var

    n,

    check_n,

    : integer;

    flag : boolean;

    Begin

    write ('Введите чило') ;

    readln (n) ;

    {Проверяется, является ли n четным}

    if n mod 2 = 0

    then

    flag = true;

    else

    flag = false;

    {Проверяется, является ли n двухзначным}

    if n div 10 0

    then

    flag = true;

    else

    flag = false;

    if flag

    then

    writeln ('Число ', n, ' является четным двухзначным') ;

    else

    writeln ('Число ', n, ' не является четным двухзначным') ;

    End.
Знаете ответ на вопрос?
Не уверены в ответе?
Правильный ответ на вопрос 👍 «Напишите программу для решения задачи Определить является ли данное число n чётным двухзначным числом ...» по предмету 📗 Информатика. Развернутая система поиска нашего сайта обязательно приведёт вас к нужной информации. Как вариант - оцените ответы на похожие вопросы. Но если вдруг и это не помогло - задавайте свой вопрос знающим оппонентам, которые быстро дадут на него ответ!
Искать готовые ответы