Задать вопрос
11 августа, 18:15

Составить программу для решения задачи:

"Ввести число, обозначающее размер одной фотографии в Мбайтах. Определить, сколько фотографий поместится на флэш-карту объёмом 2 Гбайта."

Язык программирования: Pascal

+3
Ответы (1)
  1. 11 августа, 19:46
    0
    1. С вещественными числами

    var

    k:real;

    begin

    Write ('Размер фотографии, мб: ') ; Read (k) ;

    Writeln ('На flash-card объемом 2 Гб поместится фото: ',

    Trunc (2*1024/k))

    end.

    Пример

    Размер фотографии, мб: 3.27

    На flash-card объемом 2 Гб поместится фото: 626

    2. С целыми числами

    var

    k:integer;

    begin

    Write ('Размер фотографии, мб: ') ; Read (k) ;

    Writeln ('На flash-card объемом 2 Гб поместится фото: ',2*1024 div k)

    end.

    Пример

    Размер фотографии, мб: 3

    На flash-card объемом 2 Гб поместится фото: 682
Знаете ответ на вопрос?
Не уверены в ответе?
Правильный ответ на вопрос 👍 «Составить программу для решения задачи: "Ввести число, обозначающее размер одной фотографии в Мбайтах. Определить, сколько фотографий ...» по предмету 📗 Информатика. Развернутая система поиска нашего сайта обязательно приведёт вас к нужной информации. Как вариант - оцените ответы на похожие вопросы. Но если вдруг и это не помогло - задавайте свой вопрос знающим оппонентам, которые быстро дадут на него ответ!
Искать готовые ответы