Задать вопрос
24 августа, 17:44

В первый день спортсмен пробежал x километров, а затем он каждый день увеличивал пробег на 10% от предыдущего значения. По данному числу y определите номер дня, на который пробег спортсмена составит не менее y километров. Программа получает на вход действительные числа x и y и должна вывести одно натуральное число.

+5
Ответы (2)
  1. 24 августа, 20:38
    -1
    var

    x, y:real;

    n:integer;

    begin

    readln (x) ;

    readln (y) ;

    while x
    x:=x*0.1+x;

    n:=n+1;

    end;

    writeln ('den=', n)

    end.
  2. 24 августа, 21:20
    0
    var

    x, y:real;

    day:integer;

    begin

    readln (x) ;

    readln (y) ;

    day : = 1;

    while x < y do

    begin

    x : = x * 1.1;

    day : = day + 1;

    end;

    writeln (day) ;

    end.
Знаете ответ на вопрос?
Не уверены в ответе?
Правильный ответ на вопрос 👍 «В первый день спортсмен пробежал x километров, а затем он каждый день увеличивал пробег на 10% от предыдущего значения. По данному числу y ...» по предмету 📗 Информатика. Развернутая система поиска нашего сайта обязательно приведёт вас к нужной информации. Как вариант - оцените ответы на похожие вопросы. Но если вдруг и это не помогло - задавайте свой вопрос знающим оппонентам, которые быстро дадут на него ответ!
Искать готовые ответы