Задать вопрос
14 февраля, 13:16

Дано натуральное число. найти номер цифры 3 в нем, считая от конца

+3
Ответы (1)
  1. 14 февраля, 13:42
    0
    Var a, bug, m:integer;

    s:string;

    begin;

    readln (a) ;

    str (a, s) ; / / переводим число в строку

    writeln ('Result:') ;

    while pos ('3', s) 0 do / / пока 3 есть в строке выполнять

    begin;

    m:=length (s) - pos ('3', s) + 1; / / длина строки-позиция тройки+1

    delete (s, pos ('3', s),1) ; / / удаляем 3 из строки чтобы можно было проверить след.

    writeln (m) ;

    end;

    end.
Знаете ответ на вопрос?
Не уверены в ответе?
Правильный ответ на вопрос 👍 «Дано натуральное число. найти номер цифры 3 в нем, считая от конца ...» по предмету 📗 Информатика. Развернутая система поиска нашего сайта обязательно приведёт вас к нужной информации. Как вариант - оцените ответы на похожие вопросы. Но если вдруг и это не помогло - задавайте свой вопрос знающим оппонентам, которые быстро дадут на него ответ!
Искать готовые ответы
Похожие вопросы по информатике
1. Дано натуральное число. Найти первую цифру данного числа. 2. Дано натуральное число. Определить количество троек в нем. 3. Дано натуральное число. Определить количество четных цифр в нем. Все это при помощи цикла:while
Ответы (1)
Программирование цикл вайл язык С Вопрос №737412 (тип: C) Дано натуральное число N (N
Ответы (1)
Помогите решить! 1) Дано натуральное трехзначное число N. Определить сумму и произведение его цифр. 2) Дано натуральное трехзначное число N. Найдите число, образованное перестановкой цифр исходного числа в обратном порядке.
Ответы (1)
Помогите написать программу Паскаль, очень прошу, вообще не шарю в программах, а так 2 поставят! Задача "A": Ввести натуральное число и найти сумму его цифр. Пример: Введите натуральное число: 12345. Сумма цифр 15.
Ответы (2)
Уровень B. Задача M. Две одинаковые цифры рядом Напишите программу, которая определяет, верно ли, что введённое число содержит две одинаковых цифры, стоящие рядом (как, например, 221). Входные данные Входная строка содержит одно натуральное число.
Ответы (1)