Задать вопрос
19 октября, 17:43

Составьте программу (в Pascal) "Угадай". Программа задумывает случайное число в диапазоне от 0 до 99.

Программа задумывает случайное число в диапазоне от 0 до 99. После каждой попытки играющего прога выводит сообщение "больше", "меньше", "угадано". Дается 10 попыток. Программа завершается, если дан правильный ответ или попытки закончились.

+4
Ответы (1)
  1. 19 октября, 20:33
    0
    Program ugadai;

    uses crt;

    var

    i, z, o:integer;

    begin

    randomize;

    writeln ('Введите число от 0 до 99:') ;

    z:=random (100) ;

    for i: = 1 to 10 do

    begin

    read (o) ;

    if (o = z) then

    begin

    writeln ('Вы угадали!') ;

    break;

    end else begin

    if (i = 10) then begin

    writeln ('Жалко, но число не отгаданно. Загаданное число было ', z) ;

    end else begin

    writeln ('Упс! У вас еще ',10 - i,' попопыток. Введите число:') ;

    end;

    end;

    end;

    end.
Знаете ответ на вопрос?
Не уверены в ответе?
Правильный ответ на вопрос 👍 «Составьте программу (в Pascal) "Угадай". Программа задумывает случайное число в диапазоне от 0 до 99. Программа задумывает случайное число ...» по предмету 📗 Информатика. Развернутая система поиска нашего сайта обязательно приведёт вас к нужной информации. Как вариант - оцените ответы на похожие вопросы. Но если вдруг и это не помогло - задавайте свой вопрос знающим оппонентам, которые быстро дадут на него ответ!
Искать готовые ответы