Задать вопрос
20 марта, 22:26

Структурные операторы в языке pascal: Развилка и выбор.

1. Даны целые цисла m и n. если числа не равны, то заменить каждое из них одним и тем же числом, равным большему из исходных, а если равны, то заменить числа нулями.

2. Составить программу, которая по заданному году и номера месяца m определяет количество дней в этом месяце.

+1
Ответы (1)
  1. 20 марта, 23:17
    0
    Первая прога:

    program pr1;

    uses crt

    var m, n:real;

    begin

    clrscr;

    writeln ('insert the numbers') ;

    readln (m, n) ;

    if m n then begin

    if m > n then begin

    n:=m;

    end

    else begin

    m:=n;

    writeln (m, n) ;

    end;

    end

    else begin

    m:=0;

    n:=0;

    writeln (m, n) ;

    end;

    end.

    Вторая прога:

    program pr2;

    ues crt

    var y, m, d, k: integer;

    begin

    clrscr;

    writeln ('insert the year) ;

    readln (y) ;

    writeln ('insert the month') ;

    readln (m) ;

    if m > 12 then begin

    writeln ('error') ;

    end;

    if m mod 2 0 then begin

    d: = 31;

    end;

    if m=2 then begin

    d: = 28;

    end;

    if m mod 2 = 0 then begin

    d:=30;

    end;

    writeln ('the number of the days in your month:') ;

    writeln (d) ;

    end.
Знаете ответ на вопрос?
Не уверены в ответе?
Правильный ответ на вопрос 👍 «Структурные операторы в языке pascal: Развилка и выбор. 1. Даны целые цисла m и n. если числа не равны, то заменить каждое из них одним и ...» по предмету 📗 Информатика. Развернутая система поиска нашего сайта обязательно приведёт вас к нужной информации. Как вариант - оцените ответы на похожие вопросы. Но если вдруг и это не помогло - задавайте свой вопрос знающим оппонентам, которые быстро дадут на него ответ!
Искать готовые ответы