Задать вопрос
8 ноября, 03:34

Составить программу в Паскале:

Найти наибольшее целое n такое что:

a) 3n^4-730n<5

b) e^n-1000Ln*n<=10

+5
Ответы (1)
  1. 8 ноября, 07:19
    0
    1) Если использовать последний Паскаль АВС, который умеет вычислять степень (Power), то вот вариант программы:

    var

    n:integer;

    s:real; {вообще, он целый, но мой компилятор не пропускает, почему-то считает, что результат вычислений будет real}

    begins:=0;

    n:=1;

    while s<5 do

    begin

    s:=3*power (n, 4) - 730*n; {для старого Паскаля напиши так: s:=3*sqr (sqr (n)) - 730*n}

    n:=n+1

    end;

    writeln (n)

    end.

    2)

    var n, s:real;

    begin

    s:=0;

    n:=1;

    while s<=10 do

    begin

    s:=exp (n) - 1000*Ln (n) ;

    n:=n+1

    end;

    writeln (n)

    end.
Знаете ответ на вопрос?
Не уверены в ответе?
Правильный ответ на вопрос 👍 «Составить программу в Паскале: Найти наибольшее целое n такое что: a) 3n^4-730n ...» по предмету 📗 Информатика. Развернутая система поиска нашего сайта обязательно приведёт вас к нужной информации. Как вариант - оцените ответы на похожие вопросы. Но если вдруг и это не помогло - задавайте свой вопрос знающим оппонентам, которые быстро дадут на него ответ!
Искать готовые ответы