Задать вопрос
28 декабря, 23:49

Решите на пасхале

Задача:

Найти количество четных цифр натурального числа.

Формат ввода:

На вход подается натуральное, не превосходящее 30000.

Формат вывода:

Целое число.

Пример входных данных

321

Пример выходных данных

1

+2
Ответы (1)
  1. 29 декабря, 00:23
    0
    Var

    num, ct: integer;

    begin

    read (num) ;

    ct : = 0;

    while num 0 do

    begin

    if (num MOD 10) MOD 2 = 0 then

    begin

    ct + = 1;

    num : = num div 10;

    end else num : = num div 10;

    end;

    write (ct) ;

    end.
Знаете ответ на вопрос?
Не уверены в ответе?
Правильный ответ на вопрос 👍 «Решите на пасхале Задача: Найти количество четных цифр натурального числа. Формат ввода: На вход подается натуральное, не превосходящее ...» по предмету 📗 Информатика. Развернутая система поиска нашего сайта обязательно приведёт вас к нужной информации. Как вариант - оцените ответы на похожие вопросы. Но если вдруг и это не помогло - задавайте свой вопрос знающим оппонентам, которые быстро дадут на него ответ!
Искать готовые ответы
Похожие вопросы по информатике
Задача: Подсчитать сумму 1! + 2! + 3! + ... N! Где, например, 5! - - факториал числа 5 и 5! = 1*2*3*4*5 Формат ввода: На вход подается натуральное число n не превосходящих 10. Формат вывода: Целое число - результат вычисления формулы.
Ответы (1)
С некоторого момента прошло N дней. Сколько полных недель прошло за этот период. Формат входных данных На вход программе подается 0≤N≤106. Формат выходных данных Вывести целое число - ответ на вопрос. Примеры: Вход 100 Выход 14
Ответы (1)
Напишите рекурсивную функцию вычисления суммы цифр натурального числа. Формат входных данных На вход ваша программа получает одно натуральное число n (n
Ответы (1)
Дан массив целых чисел в диапазоне от - 30000 до 30000. Отсортировать его по убыванию. Методом простого выбора. Формат ввода: В первой строке - количество элементов массива не превосходящее 100. На второй строке через пробел элементы массива.
Ответы (1)
Напишите рекурсивную функцию подсчёта количества цифр в натуральном числе. Формат входных данных На вход ваша программа получает одно натуральное число n (1≤n≤216-11≤n≤216-1). Формат выходных данных Выведите одно число - количество цифр в числе n.
Ответы (2)