Задать вопрос
7 октября, 18:02

Нужно написать программу на pascal. Даны натуральное число n и вещественные числа а1, а2, а3, ..., аn. Определить сумму квадратов вещественных чисел.

+2
Ответы (1)
  1. 7 октября, 18:13
    0
    Var

    i, n:integer;

    s, t:real;

    begin

    Write ('n=') ; Readln (n) ;

    s:=0;

    for i:=1 to n do begin

    Read (t) ;

    s:=s+t*t

    end;

    Writeln ('Сумма квадратов равна ', s)

    end.

    Пример

    n=5

    -23.1 42.6 146 0 0.12

    Сумма квадратов равна 23664.3844
Знаете ответ на вопрос?
Не уверены в ответе?
Правильный ответ на вопрос 👍 «Нужно написать программу на pascal. Даны натуральное число n и вещественные числа а1, а2, а3, ..., аn. Определить сумму квадратов ...» по предмету 📗 Информатика. Развернутая система поиска нашего сайта обязательно приведёт вас к нужной информации. Как вариант - оцените ответы на похожие вопросы. Но если вдруг и это не помогло - задавайте свой вопрос знающим оппонентам, которые быстро дадут на него ответ!
Искать готовые ответы