Задать вопрос
8 декабря, 01:20

Задача №309. Голосование

Напишите "функцию голосования"

function Election (x, y, z:boolean) : boolean

Входные данные

Вводится 3 числа - x, y и z (x, y и z равны 0 или 1, 0 соответствует значению false, 1 соответствует значению true).

Выходные данные

Необходимо вывести значение функции от x, y и z.

Примеры

0 0 1

0

+5
Ответы (1)
  1. 8 декабря, 03:48
    0
    Program n1;

    var x, y, z: integer;

    function Election (x, y, z: integer) : boolean;

    begin

    if (x=0) and (y=0) then Election:=false

    else

    begin

    Election:=true;

    if (x=0) and (z=0) then Election:=false

    else

    begin

    Election:=true;

    if (y=0) and (z=0) then Election:=false

    else Election:=true;

    end;

    end;

    end;

    begin

    readln (x, y, z) ;

    if Election (x, y, z) = true then

    writeln (1) else writeln (0) ;

    end.
Знаете ответ на вопрос?
Не уверены в ответе?
Правильный ответ на вопрос 👍 «Задача №309. Голосование Напишите "функцию голосования" function Election (x, y, z:boolean) : boolean Входные данные Вводится 3 числа - x, ...» по предмету 📗 Информатика. Развернутая система поиска нашего сайта обязательно приведёт вас к нужной информации. Как вариант - оцените ответы на похожие вопросы. Но если вдруг и это не помогло - задавайте свой вопрос знающим оппонентам, которые быстро дадут на него ответ!
Искать готовые ответы