Задать вопрос
9 января, 16:38

На шахматной доске в клетке (x1, y1) (x1, y1) находится шахматный конь. Определите, бьёт ли конь поле (x2, y2) (x2, y2).

Формат входных данных

На вход программе даются четыре целых числа x1, y1, x2, y2 (1≤x1, y1, x2, y2≤8) - координаты двух клеток на шахматной доске раpмера 8*8.

Формат выходных данных

Требуется вывести 11, если поле находится под боем коня, или 00, если нет.

+1
Ответы (1)
  1. 9 января, 18:35
    0
    Var

    x1, y1, x2, y2: integer;

    begin

    readln (x1, y1, x2, y2) ;

    if abs (x2 - x1) + abs (y2 - y1) = 3 then

    writeln ('11')

    else

    writeln ('00') ;

    end.
Знаете ответ на вопрос?
Не уверены в ответе?
Правильный ответ на вопрос 👍 «На шахматной доске в клетке (x1, y1) (x1, y1) находится шахматный конь. Определите, бьёт ли конь поле (x2, y2) (x2, y2). Формат входных ...» по предмету 📗 Информатика. Развернутая система поиска нашего сайта обязательно приведёт вас к нужной информации. Как вариант - оцените ответы на похожие вопросы. Но если вдруг и это не помогло - задавайте свой вопрос знающим оппонентам, которые быстро дадут на него ответ!
Искать готовые ответы