Задать вопрос
7 мая, 22:58

Даны два натуральных числа. Определить в каком числе первая цифра больше?

написать программу

+4
Ответы (1)
  1. 8 мая, 01:37
    0
    Var n, k:integer;

    begin

    writeln ('Введите 2 числа через пробел') ;

    readln (n, k) ;

    if (strToInt (intToStr (n) [1]) > strToInt (intToStr (k) [1])) then writeln ('У первого числа первая цифра больше') ;

    if (strToInt (intToStr (n) [1]) < strToInt (intToStr (k) [1])) then writeln ('У воторого числа первая цифра больше') ;

    if (strToInt (intToStr (n) [1]) = strToInt (intToStr (k) [1])) then writeln ('У первого числа и воторого числа первые цифры равны') ;

    end.
Знаете ответ на вопрос?
Не уверены в ответе?
Правильный ответ на вопрос 👍 «Даны два натуральных числа. Определить в каком числе первая цифра больше? написать программу ...» по предмету 📗 Информатика. Развернутая система поиска нашего сайта обязательно приведёт вас к нужной информации. Как вариант - оцените ответы на похожие вопросы. Но если вдруг и это не помогло - задавайте свой вопрос знающим оппонентам, которые быстро дадут на него ответ!
Искать готовые ответы