Задать вопрос
15 июня, 15:08

Напишите программу, которая запрашивает у пользователя ввод чисел, пока не будет нажата цифра "ноль". На экран выводит сумму всех введенных чисел

+3
Ответы (2)
  1. 15 июня, 16:28
    0
    Program numSum;

    var inp, sum:longint;

    begin

    repeat

    readln (inp) ;

    sum:=sum+inp;

    until inp=0; write ('Sum - ', sum) ; readln;

    end.
  2. 15 июня, 17:51
    0
    Var a, s:integer;

    begin

    writeln ('Введите целое число') ;

    a:=1;

    while a0 do

    begin

    readln (a) ;

    s:=a+s;

    end;

    writeln ('Сумма всех введенных чисел = ', s) ;

    end.
Знаете ответ на вопрос?
Не уверены в ответе?
Правильный ответ на вопрос 👍 «Напишите программу, которая запрашивает у пользователя ввод чисел, пока не будет нажата цифра "ноль". На экран выводит сумму всех введенных ...» по предмету 📗 Информатика. Развернутая система поиска нашего сайта обязательно приведёт вас к нужной информации. Как вариант - оцените ответы на похожие вопросы. Но если вдруг и это не помогло - задавайте свой вопрос знающим оппонентам, которые быстро дадут на него ответ!
Искать готовые ответы