Задать вопрос
14 ноября, 16:01

Одна ручка стоит A Гривен и B Копеек! Написать программу которая определяет, сколько ручек можео купить за C Гривен и D копеек, а также сколько денег останеться!

+4
Ответы (1)
  1. 14 ноября, 16:25
    0
    Var a, b, c, d, e, f, k, m:integer;

    begin

    writeln ('A, B:') ;

    readln (a, b) ;

    writeln ('C, D:') ;

    readln (c, d) ;

    e:=a*100+b;

    f:=c*100+d;

    k:=e div f;

    m:=e-k*f;

    writeln ('k = ', k) ;

    writeln ('Останется: ', m div 100,' гр ', m mod 100,' коп') ;

    end.

    Пример:

    A, B:

    28 15

    C, D:

    3 75

    k = 7

    Останется: 1 гр 90 коп
Знаете ответ на вопрос?
Не уверены в ответе?
Правильный ответ на вопрос 👍 «Одна ручка стоит A Гривен и B Копеек! Написать программу которая определяет, сколько ручек можео купить за C Гривен и D копеек, а также ...» по предмету 📗 Информатика. Развернутая система поиска нашего сайта обязательно приведёт вас к нужной информации. Как вариант - оцените ответы на похожие вопросы. Но если вдруг и это не помогло - задавайте свой вопрос знающим оппонентам, которые быстро дадут на него ответ!
Искать готовые ответы