Задать вопрос
16 сентября, 09:34

Напишите программу на Python

Натуральное число называется автоморфным, если оно равно последним цифрам своего квадрата. Например, 252 = 625. Напишите программу, которая получает натуральное число N и выводит на экран все автоморфные числа, не превосходящие N.

Пример:

Введите N:

1000

1*1=1

5*5=25

6*6=36

25*25=625

76*76=5776

+3
Ответы (1)
  1. 16 сентября, 13:14
    0
    Только Паскаль или C + + (Пс на Кибер форуме попроси перевести)

    Var

    i, N : integer;

    Begin

    Write ('N = ') ; Readln (n) ;

    For I:=1 to N do

    Proverka (i) ;

    Writeln;

    End.
Знаете ответ на вопрос?
Не уверены в ответе?
Правильный ответ на вопрос 👍 «Напишите программу на Python Натуральное число называется автоморфным, если оно равно последним цифрам своего квадрата. Например, 252 = ...» по предмету 📗 Информатика. Развернутая система поиска нашего сайта обязательно приведёт вас к нужной информации. Как вариант - оцените ответы на похожие вопросы. Но если вдруг и это не помогло - задавайте свой вопрос знающим оппонентам, которые быстро дадут на него ответ!
Искать готовые ответы