Задать вопрос
22 апреля, 23:23

Напишите программу, которая

сортирует одномерный массив.

Дана матрица размерами 4 на 4. Заполните ее следующим образом: Если сумма индексов четная - в ячейке должно содержаться произведение индексов, если сумма индексов нечетная - в ячейке должна содержаться сумма индексов.

Постройте график параметрической функции, если x (t) = cos (t2), y (t) = sin (t2).

В стране Цифра есть 9 городов с названиями 1, 2, 3, 4, 5, 6, 7, 8, 9. Путешественник обнаружил, что два города соединены авиалинией в том и только в том случае, если двузначное число, составленное из цифр-названий этих городов, делится на 3. Можно ли добраться из города 1 в город 9?

В городе Маленьком 15 телефонов. Можно ли их соединить проводами так, чтобы было 4 телефона, каждый из которых соединен с тремя другими, 8 телефонов, каждый из которых соединен с шестью, и 3 телефона, каждый из которых соединен с пятью другими?

+2
Ответы (1)
  1. 23 апреля, 02:14
    0
    №1

    #include

    using namespace std;

    int main () {

    int * arr; int size;

    cout << "n = ";

    cin >> size;

    if (size < = 0) {

    cerr << "Invalid size" << endl; return 1;

    }

    arr = new int[size];

    for (int i = 0; i < size; i++) {

    cout << "arr[" << i <> arr[i];

    }

    int temp;

    for (int i = 0; i < size - 1; i++) {

    for (int j = 0; j < size - i - 1; j++) {

    if (arr[j] > arr[j + 1]) {

    temp = arr[j]; arr[j] = arr[j + 1]; arr[j + 1] = temp;

    }

    }

    }

    for (int i = 0; i < size; i++) {

    cout << arr[i] << " ";

    }

    cout << endl;

    delete[] arr;

    return 0;

    }
Знаете ответ на вопрос?
Не уверены в ответе?
Правильный ответ на вопрос 👍 «Напишите программу, которая сортирует одномерный массив. Дана матрица размерами 4 на 4. Заполните ее следующим образом: Если сумма индексов ...» по предмету 📗 Информатика. Развернутая система поиска нашего сайта обязательно приведёт вас к нужной информации. Как вариант - оцените ответы на похожие вопросы. Но если вдруг и это не помогло - задавайте свой вопрос знающим оппонентам, которые быстро дадут на него ответ!
Искать готовые ответы