Задать вопрос
8 мая, 07:38

Напишите программу, которая получает с клавиатуры возрасты трёх человек (Антона, Бориса и Виктора) и определяет, кто из них старше. Пример: Возраст Антона: 15 Возраст Бориса: 17 Возраст Виктора: 16 Ответ: Борис старше всех.

+4
Ответы (1)
  1. 8 мая, 08:57
    0
    Program prog;

    uses crt;

    var a, b, v:integer;

    begin

    clrscr;

    write ('Возраст Антона = ') ;

    readln (a) ;

    write ('Возраст Бориса = ') ;

    readln (b) ;

    write ('Возраст Виктора = ') ;

    readln (v) ;

    writeln;

    if (a>b) and (a>v) then writeln ('Антон старше всех.') ;

    if (b>a) and (b>v) then writeln ('Борис старше всех.') ;

    if (v>a) and (v>b) then writeln ('Виктор старше всех.') ;

    if (a=b) and (a>v) then writeln ('Антон и Борис старше Виктора') ;

    if (a=v) and (a>b) then writeln ('Антон и Виктор старше Бориса') ;

    if (b=v) and (b>a) then writeln ('Борис и Виктор старше Антона') ;

    if (a=b) and (a=v) then writeln ('Антон, Борис и Виктор одного возраста') ;

    end.
Знаете ответ на вопрос?
Не уверены в ответе?
Правильный ответ на вопрос 👍 «Напишите программу, которая получает с клавиатуры возрасты трёх человек (Антона, Бориса и Виктора) и определяет, кто из них старше. Пример: ...» по предмету 📗 Информатика. Развернутая система поиска нашего сайта обязательно приведёт вас к нужной информации. Как вариант - оцените ответы на похожие вопросы. Но если вдруг и это не помогло - задавайте свой вопрос знающим оппонентам, которые быстро дадут на него ответ!
Искать готовые ответы