Задать вопрос
9 ноября, 17:48

Решение нужно в паскале. составьте программу вычисления суммы элементов двумерного массива A (N, N), расположенных под побочной диагональю

+2
Ответы (1)
  1. 9 ноября, 19:02
    0
    Const n=4;

    Var x:array [1 ... n, 1 ... n] of integer;

    s, i, j:integer;

    begin

    randomize;

    for i:=1 to n do begin

    for j:=1 to n do begin

    x[i, j] : = random (100) ;

    write (x[i, j]:6) ;

    end;

    writeln;

    end;

    s:=0;

    for i:=1 to n do

    for j: = 1 to n do

    if i + j < n + 1

    then

    s : = s + x[i, j];

    writeln ('s=', s) ;

    readln;

    end.
Знаете ответ на вопрос?
Не уверены в ответе?
Правильный ответ на вопрос 👍 «Решение нужно в паскале. составьте программу вычисления суммы элементов двумерного массива A (N, N), расположенных под побочной диагональю ...» по предмету 📗 Информатика. Развернутая система поиска нашего сайта обязательно приведёт вас к нужной информации. Как вариант - оцените ответы на похожие вопросы. Но если вдруг и это не помогло - задавайте свой вопрос знающим оппонентам, которые быстро дадут на него ответ!
Искать готовые ответы