Задать вопрос
2 октября, 06:15

Помогите написать программу Если в массиве (из n чисел) есть хотя бы одна тройка соседних чисел, в которой средний элемент больше своих "соседей", т. е. предшествующего и последующего, то напечатать все элементы, предшествующие элементам последней из таких троек.

+3
Ответы (1)
  1. 2 октября, 10:06
    0
    Type mas=Array [1 ... 100] of integer;

    var i, n, itre:integer;

    a:mas;

    begin

    readln (n) ;

    for i:=1 to n

    do read (A[i]) ;

    for i:=2 to n-1

    do if (A[i]>A[i-1]) and (A[i]>A[i+1])

    then itre:=i;

    for i:=1 to itre-2

    do writeln (A[i]) ;

    end.
Знаете ответ на вопрос?
Не уверены в ответе?
Правильный ответ на вопрос 👍 «Помогите написать программу Если в массиве (из n чисел) есть хотя бы одна тройка соседних чисел, в которой средний элемент больше своих ...» по предмету 📗 Информатика. Развернутая система поиска нашего сайта обязательно приведёт вас к нужной информации. Как вариант - оцените ответы на похожие вопросы. Но если вдруг и это не помогло - задавайте свой вопрос знающим оппонентам, которые быстро дадут на него ответ!
Искать готовые ответы