Задать вопрос
1 сентября, 20:26

Написать программу на паскале для определения числа членов ряда, вошедших в сумму. Исходные данные 0.62, точность вычисления 10^-4.

+5
Ответы (1)
  1. 1 сентября, 23:52
    0
    Const eps=1e-4;

    var n, z:integer; x, sx, an, s:real;

    begin

    x:=0.62;

    sx:=sin (x) ;

    n:=1; z:=-1;

    an:=1; s:=0;

    while abs (an) >eps do

    begin

    z:=-z;

    n:=n+1;

    an:=z*sx / (n * (n*n-1)) ;

    s:=s+an;

    end;

    writeln ('k = ', n-1,' s = ', s) ;

    end.

    Результат:

    k = 17 s = 7.92376332816429E-002
Знаете ответ на вопрос?
Не уверены в ответе?
Правильный ответ на вопрос 👍 «Написать программу на паскале для определения числа членов ряда, вошедших в сумму. Исходные данные 0.62, точность вычисления 10^-4. ...» по предмету 📗 Информатика. Развернутая система поиска нашего сайта обязательно приведёт вас к нужной информации. Как вариант - оцените ответы на похожие вопросы. Но если вдруг и это не помогло - задавайте свой вопрос знающим оппонентам, которые быстро дадут на него ответ!
Искать готовые ответы