Задать вопрос
1 января, 19:54

Написать программу в паскале

Дано три массива A, B, C состоящее из 10 элементов. Присвоить массиву D среднее арифметическое каждого элемента этих трех массивов.

+2
Ответы (1)
  1. 1 января, 23:00
    0
    Uses crt;

    Var a, b, c, d; array [1 ... 10] of integer;

    I:integer;

    Begin

    Clrscr;

    Begin

    For i:=1 to 10 do

    Begin

    a[i]:=random (50) + 1;

    b[i]:=random (50) + 1;

    c[i]:=random (50) + 1;

    d[i]: = (a[i]+b[i]+c[i]) div 3;

    end;

    Write ('A) ') ;

    For i:=1 to 10 do

    write (a[i],' ') ;

    Writeln;

    write ('B) ') ;

    For i:=1 to 10 do

    write (b[i],' ') ;

    Writeln;

    Write ('C) ') ;

    For i:=1 to 10 do

    write (c[i],' ') ;

    Writeln;

    Writeln ('Средние значения ') ;

    Write ('D) ') ;

    For i:=1 to 10 do

    write (d[i],' ') ;

    Writeln;

    Readkey;

    End.
Знаете ответ на вопрос?
Не уверены в ответе?
Правильный ответ на вопрос 👍 «Написать программу в паскале Дано три массива A, B, C состоящее из 10 элементов. Присвоить массиву D среднее арифметическое каждого ...» по предмету 📗 Информатика. Развернутая система поиска нашего сайта обязательно приведёт вас к нужной информации. Как вариант - оцените ответы на похожие вопросы. Но если вдруг и это не помогло - задавайте свой вопрос знающим оппонентам, которые быстро дадут на него ответ!
Искать готовые ответы