Задать вопрос
17 июля, 04:33

Написать программу по задаче: Автомат получает на вход четырехзначное десятичное число. По полученному числу строится новое десятичное число по следующим правилам. 1. Вычисляются два числа - сумма двух старших и сумма двух младших разрядов. 2. Полученные два числа записываются друг за другом в порядке невозрастания (без разделителей).

+3
Ответы (1)
  1. 17 июля, 06:57
    0
    Var

    A, B:integer;

    Begin

    ReadLn (A) ;

    B: = (A div 1000) + ((A div 100) mod 10) ;

    A: = ((A div 10) mod 10) + (A mod 10) ;

    if A>=B then Write (B, A)

    else if B>=A then Write (B, A)

    End.
Знаете ответ на вопрос?
Не уверены в ответе?
Правильный ответ на вопрос 👍 «Написать программу по задаче: Автомат получает на вход четырехзначное десятичное число. По полученному числу строится новое десятичное ...» по предмету 📗 Информатика. Развернутая система поиска нашего сайта обязательно приведёт вас к нужной информации. Как вариант - оцените ответы на похожие вопросы. Но если вдруг и это не помогло - задавайте свой вопрос знающим оппонентам, которые быстро дадут на него ответ!
Искать готовые ответы