Задать вопрос
22 декабря, 19:16

Написать программу, которая заполняет элементами массив по правилу: а (I) = (i^4/7i-2), выводит его элементы на экран с двумя знаками после запятой и затем выводит новый массив, в котором заменены на противоположные знаки элементов исходного массива. I=1,2,3 ... 10

+1
Ответы (1)
  1. 22 декабря, 22:10
    0
    Var a:array[1 ... 10]of Integer;

    i, k:Integer;

    p:LongInt;

    begin

    p:=1;

    k:=0;

    Writeln ('Сгенерированный массив:') ;

    Randomize;

    for i:=1 to 10 dobegina[i]:=Random (10) + 1; if a[i] mod 2=1 then p:=p*a[i] else k:=k+1;

    Write (a[i],' ') ;

    end;

    Writeln;

    Writeln ('Произведение нечетных:', p) ;

    Writeln ('Количество четных:', k) ;

    Readln;

    end.
Знаете ответ на вопрос?
Не уверены в ответе?
Правильный ответ на вопрос 👍 «Написать программу, которая заполняет элементами массив по правилу: а (I) = (i^4/7i-2), выводит его элементы на экран с двумя знаками после ...» по предмету 📗 Информатика. Развернутая система поиска нашего сайта обязательно приведёт вас к нужной информации. Как вариант - оцените ответы на похожие вопросы. Но если вдруг и это не помогло - задавайте свой вопрос знающим оппонентам, которые быстро дадут на него ответ!
Искать готовые ответы