Задать вопрос
12 июня, 00:28

Составьте программу, проверяющую есть ли в двумерном массиве A (N, N) столбцы, все элементы которых различны.

+5
Ответы (1)
  1. 12 июня, 01:32
    0
    Const n=4;

    Var x:array [1 ... n, 1 ... n] of integer;

    k, s, i, j:integer;

    begin

    randomize;

    for i:=1 to n do begin

    for j:=1 to n do begin

    x[i, j] : = random (100) ;

    write (x[i, j]:6) ;

    end;

    writeln;

    end;

    for i : = 1 to n do

    for j : = 1 to n do

    for k : = j+1 to n do

    if x[j, i]=x[k, i]

    then

    writeln ('NO')

    else

    writeln ('YES') ;

    readln;

    end.
Знаете ответ на вопрос?
Не уверены в ответе?
Правильный ответ на вопрос 👍 «Составьте программу, проверяющую есть ли в двумерном массиве A (N, N) столбцы, все элементы которых различны. ...» по предмету 📗 Информатика. Развернутая система поиска нашего сайта обязательно приведёт вас к нужной информации. Как вариант - оцените ответы на похожие вопросы. Но если вдруг и это не помогло - задавайте свой вопрос знающим оппонентам, которые быстро дадут на него ответ!
Искать готовые ответы