Задать вопрос
25 июля, 17:39

Составьте программу в паскале abc. Дано количество информации в битах. Вывести в удобной форме в более крупных единицах. (до Мб).

Пример вывода:

10240 бит = 1280 байт = 1,25 Кб = 0,0012 Мб. Прошу помогите с формулами хотябы

+2
Ответы (2)
  1. 25 июля, 18:10
    0
    Var b:integer;

    begin

    write ('Введите количество бит: ') ;

    readln (b) ;

    write (b,' бит = ', b/8,' байт = ') ;

    writeln (b/8/1024,' Кбайт = ', b/8/1024/1024:6:4,' Мбайт') ;

    end.

    Пример:

    Введите количество бит: 10240

    10240 бит = 1280 байт = 1.25 Кбайт = 0.0012 Мбайт
  2. 25 июля, 21:14
    0
    Var

    b:real;

    begin

    Write ('Количество информации в битах ') ; Read (b) ;

    Write (b,' бит = ') ;

    b:=b/8; Write (b,' б = ') ;

    b:=b/1024; Write (b,' Кб = ') ;

    b:=b/1024; Write (b,' Мб = ') ;

    b:=b/1024; Write (b,' Гб = ') ;

    b:=b/1024; Write (b,' Тб')

    end.

    Пример

    Количество информации в битах 10240

    10240 бит = 1280 б = 1.25 Кб = 0.001220703125 Мб = 1.19209289550781E-06 Гб = 1.16415321826935E-09 Тб
Знаете ответ на вопрос?
Не уверены в ответе?
Правильный ответ на вопрос 👍 «Составьте программу в паскале abc. Дано количество информации в битах. Вывести в удобной форме в более крупных единицах. (до Мб). Пример ...» по предмету 📗 Информатика. Развернутая система поиска нашего сайта обязательно приведёт вас к нужной информации. Как вариант - оцените ответы на похожие вопросы. Но если вдруг и это не помогло - задавайте свой вопрос знающим оппонентам, которые быстро дадут на него ответ!
Искать готовые ответы