Задать вопрос
25 июня, 12:35

В данном массиве чисел найдите среднее арифметическое положительных элементов массива.

Составить программу для Pascal ABC

+2
Ответы (1)
  1. 25 июня, 13:23
    0
    var

    arr : array[1 ... 99] of integer;

    N, s, k : integer;

    begin

    read (N) ;

    for var i : = 1 to N do begin

    arr[i] : = random (-10, 10) ;

    writeln (arr[i]) ;

    if arr[i] > 0 then begin

    s + = arr[i];

    k + = 1;

    end

    end;

    writeln (s/k) ;

    end.
Знаете ответ на вопрос?
Не уверены в ответе?
Правильный ответ на вопрос 👍 «В данном массиве чисел найдите среднее арифметическое положительных элементов массива. Составить программу для Pascal ABC ...» по предмету 📗 Информатика. Развернутая система поиска нашего сайта обязательно приведёт вас к нужной информации. Как вариант - оцените ответы на похожие вопросы. Но если вдруг и это не помогло - задавайте свой вопрос знающим оппонентам, которые быстро дадут на него ответ!
Искать готовые ответы