Задать вопрос
26 декабря, 13:34

Люди, помогите написать программу в Паскале. Нужно, чтобы сравнивалась дробная и целая часть вещественного числа, если она одна и та же, то тру, если нет, то false. Допустим 12.12 будет тру, а если нет, то фолс. Проблема в том, что через fruc и int сравнивается 12 и 0.12. Домножать на 100 нельзя, тк это универсальная программа, может быть и число 123.123

+1
Ответы (1)
  1. 26 декабря, 14:42
    0
    Var

    V: real;

    c, b: integer;

    begin

    writeln ('Введите число') ;

    readln (V) ;

    c:=round (V) ;

    V:=V-c;

    b:=c;

    while c>0 do begin

    c:=c div 10;

    V:=V*10;

    end;

    c:=round (V) ;

    V:=V-c;

    if round (V*10000) 0 then

    writeln ('части не равны')

    else begin

    if b=c then

    writeln ('части равны')

    else

    writeln ('части не равны') ;

    end;

    end.
Знаете ответ на вопрос?
Не уверены в ответе?
Правильный ответ на вопрос 👍 «Люди, помогите написать программу в Паскале. Нужно, чтобы сравнивалась дробная и целая часть вещественного числа, если она одна и та же, то ...» по предмету 📗 Информатика. Развернутая система поиска нашего сайта обязательно приведёт вас к нужной информации. Как вариант - оцените ответы на похожие вопросы. Но если вдруг и это не помогло - задавайте свой вопрос знающим оппонентам, которые быстро дадут на него ответ!
Искать готовые ответы