Задать вопрос
22 апреля, 18:17

Напишите программу, которая сначала считывает целое положительное число, а затем печатает значение меньшей из его первой и последней цифр. Исходное число не превышает 30 000. Программа должна напечатать только число, равное значению меньшей из его первой и последней цифр. Если число состоит из одной цифры, то минимальным является значение самой этой цифры.

Примеры работы программы:

Ввод: 3; Вывод: 3

Ввод: 2194; Вывод: 2

+5
Ответы (1)
  1. 22 апреля, 20:27
    0
    Var a, af, al:integer;

    begin

    writeln ('Введите число') ;

    readln (a) ;

    if a<10 then writeln ('Ответ: ', a)

    else

    if a<=99 then

    begin

    af:=a div 10;

    al:=a mod 10;

    if af>al then writeln ('Ответ: ', al) else writeln ('Ответ: ', af)

    end

    else

    if a<=999 then

    begin

    af:=a div 100;

    al:=a mod 10;

    if af>al then writeln ('Ответ: ', al) else writeln ('Ответ: ', af)

    end

    else

    if a<=9999 then

    begin

    af:=a div 1000;

    al:=a mod 10;

    if af>al then writeln ('Ответ: ', al) else writeln ('Ответ: ', af)

    end

    else

    if a<=30000 then

    begin

    af:=a div 10000;

    al:=a mod 10;

    if af>al then writeln ('Ответ: ', al) else writeln ('Ответ: ', af)

    end;

    end.
Знаете ответ на вопрос?
Не уверены в ответе?
Правильный ответ на вопрос 👍 «Напишите программу, которая сначала считывает целое положительное число, а затем печатает значение меньшей из его первой и последней цифр. ...» по предмету 📗 Информатика. Развернутая система поиска нашего сайта обязательно приведёт вас к нужной информации. Как вариант - оцените ответы на похожие вопросы. Но если вдруг и это не помогло - задавайте свой вопрос знающим оппонентам, которые быстро дадут на него ответ!
Искать готовые ответы