Задать вопрос
27 октября, 07:19

Написать программу для вычисления суммы элементов заданного числового массива

+3
Ответы (1)
  1. 27 октября, 07:46
    0
    program massiv6;

    02. uses crt;

    03. const N=10;

    04. type x=array [1 ... N] of integer;

    05. var a:x;

    06. i:integer;

    07. s:integer;

    08. begin

    09. clrscr;

    10. randomize;

    11. for i:=1 to N do

    12. begin

    13. a[i]:=-100+random (201) ;

    14. write (A[i]:5)

    15. end;

    16. writeln;

    17. s:=0;

    18. for i:=1 to N do

    19. if a[i]>0 then

    20. begin

    21. s:=s+a[i]

    22. end;

    23. writeln (‘Сумма положительных элементов = ’, s:5) ;

    24. readln

    25. end.
Знаете ответ на вопрос?
Не уверены в ответе?
Правильный ответ на вопрос 👍 «Написать программу для вычисления суммы элементов заданного числового массива ...» по предмету 📗 Информатика. Развернутая система поиска нашего сайта обязательно приведёт вас к нужной информации. Как вариант - оцените ответы на похожие вопросы. Но если вдруг и это не помогло - задавайте свой вопрос знающим оппонентам, которые быстро дадут на него ответ!
Искать готовые ответы