Задать вопрос
3 февраля, 03:49

Напишите программу, которая шифрует тексты следующим образом: Исходная строка разбивается на части по 3 символа и эти три символа перемещаются по кругу вправо на одну позицию. Если последняя группа символов состоит из 1 или 2 символов, то они остаются неизменными

turbo pascal

+3
Ответы (1)
  1. 3 февраля, 05:09
    0
    Var s:string; c:char; i:integer;

    begin

    writeln ('Введите строку:') ;

    readln (s) ;

    for i:=0 to length (s) div 3-1 do

    begin

    c:=s[3*i+3];

    s[3*i+3]:=s[3*i+2];

    s[3*i+2]:=s[3*i+1];

    s[3*i+1]:=c;

    end;

    writeln (s) ;

    end.

    Пример:

    Primer, begin, end. iPrrmeb, ieg n, den.
Знаете ответ на вопрос?
Не уверены в ответе?
Правильный ответ на вопрос 👍 «Напишите программу, которая шифрует тексты следующим образом: Исходная строка разбивается на части по 3 символа и эти три символа ...» по предмету 📗 Информатика. Развернутая система поиска нашего сайта обязательно приведёт вас к нужной информации. Как вариант - оцените ответы на похожие вопросы. Но если вдруг и это не помогло - задавайте свой вопрос знающим оппонентам, которые быстро дадут на него ответ!
Искать готовые ответы