Задать вопрос
18 сентября, 07:03

Задача Полет

Известно время вылета самолёта НН часов и ММ минут, а также продолжительность полёта (НР часов и МР минут)

Напишите программу, которая определяет время прибытия самолёта в аэропорт Назначение в формате "чс: мм"

+2
Ответы (1)
  1. 18 сентября, 09:26
    0
    Var

    h0, m0, h1, m1, h2, m2: integer;

    begin

    readln (h0, m0, h1, m1) ;

    m0 + = h0 * 60;

    m1 + = h1 * 60;

    m2 : = m0 + m1;

    h2 : = (m2 div 60) mod 24;

    m2 : = (m1 + m0) mod 60;

    h0 : = h2 div 10;

    h1 : = h2 mod 10;

    m0 : = m2 div 10;

    m1 : = m2 mod 10;

    write (h0, h1, ':', m0, m1) ;

    end.
Знаете ответ на вопрос?
Не уверены в ответе?
Правильный ответ на вопрос 👍 «Задача Полет Известно время вылета самолёта НН часов и ММ минут, а также продолжительность полёта (НР часов и МР минут) Напишите программу, ...» по предмету 📗 Информатика. Развернутая система поиска нашего сайта обязательно приведёт вас к нужной информации. Как вариант - оцените ответы на похожие вопросы. Но если вдруг и это не помогло - задавайте свой вопрос знающим оппонентам, которые быстро дадут на него ответ!
Искать готовые ответы