Задать вопрос
21 декабря, 22:22

Задание:

Написать программу, получающую с клавиатуры целое число и определяющую, верно ли, что цифры расположены в порядке возрастания.

Написать программу, получающую с клавиатуры целое число и выводящую его наоборот

(Например: вводим: 123, а выводит: 321).

+3
Ответы (1)
  1. 22 декабря, 02:14
    0
    Var

    A:longint;

    B:boolean;

    Begin

    B:=true;

    Write ('Введите целое число: ') ; ReadLn (A) ;

    A:=Abs (A) ;

    While A div 10 > 0 do

    Begin

    if A mod 10 < A div 10 mod 10 then B:=false;

    A:=A div 10

    End;

    if B then Write ('Верно')

    else Write ('Не верно')

    End.

    Var

    A:longint;

    Begin

    Write ('Введите целое число: ') ; ReadLn (A) ;

    if A < 0 then

    Begin

    Write ('-') ;

    A:=-A;

    End;

    While A > 0 do

    Begin

    Write (A mod 10) ;

    A:=A div 10

    End;

    End.
Знаете ответ на вопрос?
Не уверены в ответе?
Правильный ответ на вопрос 👍 «Задание: Написать программу, получающую с клавиатуры целое число и определяющую, верно ли, что цифры расположены в порядке возрастания. ...» по предмету 📗 Информатика. Развернутая система поиска нашего сайта обязательно приведёт вас к нужной информации. Как вариант - оцените ответы на похожие вопросы. Но если вдруг и это не помогло - задавайте свой вопрос знающим оппонентам, которые быстро дадут на него ответ!
Искать готовые ответы