Задать вопрос
17 октября, 17:38

Переведите натуральное число из двоичной системы в десятичную (в двоичном числе не более 10 цифр). Нужна программа на паскале.

Входные данные: 1

Выходные данные: 1

+2
Ответы (1)
  1. 17 октября, 19:11
    0
    Var

    n, s, p, d:longint;

    begin

    Write ('Введите двоичное число: ') ; Read (n) ;

    s:=0; p:=1;

    repeat

    d:=n mod 10;

    s:=s+d*p;

    p:=p*2;

    n:=n div 10

    until n=0;

    Writeln ('В десятичной системе это число равно ', s)

    end.

    Пример

    Введите двоичное число: 1101011

    В десятичной системе это число равно 107
Знаете ответ на вопрос?
Не уверены в ответе?
Правильный ответ на вопрос 👍 «Переведите натуральное число из двоичной системы в десятичную (в двоичном числе не более 10 цифр). Нужна программа на паскале. Входные ...» по предмету 📗 Информатика. Развернутая система поиска нашего сайта обязательно приведёт вас к нужной информации. Как вариант - оцените ответы на похожие вопросы. Но если вдруг и это не помогло - задавайте свой вопрос знающим оппонентам, которые быстро дадут на него ответ!
Искать готовые ответы