Задать вопрос
15 февраля, 08:52

Ребят, помогите с задачей. Напишите программу подсчёта суммы всех отрицательных элементов заданного целочисленного массива размером 30 элементов. Если отрицательных элементов нет, то сообщить об этом)

p. s. В паскале

+1
Ответы (1)
  1. 15 февраля, 09:58
    0
    Var

    n, i, s, k:integer;

    a:array [1 ... 30] of integer;

    begin

    writeln ('Vvedite massiv') ;

    for i:=1 to 30 do

    readln (a[i]) ;

    writeln ('Massiv') ;

    for i:=1 to 30 do

    write (a[i],' ') ;

    writeln () ;

    k:=0; s:=0;

    for i:=1 to 30 do

    if a[i]<0 then

    begin

    s:=a[i]+s;

    k:=1;

    end;

    if k=1 then

    writeln ('Summa otricatelnih elementov: ', s)

    else

    writeln ('Otricatelnih elementov net') ;

    readln () ;

    end.
Знаете ответ на вопрос?
Не уверены в ответе?
Правильный ответ на вопрос 👍 «Ребят, помогите с задачей. Напишите программу подсчёта суммы всех отрицательных элементов заданного целочисленного массива размером 30 ...» по предмету 📗 Информатика. Развернутая система поиска нашего сайта обязательно приведёт вас к нужной информации. Как вариант - оцените ответы на похожие вопросы. Но если вдруг и это не помогло - задавайте свой вопрос знающим оппонентам, которые быстро дадут на него ответ!
Искать готовые ответы