Задать вопрос
15 ноября, 06:52

Написать программу в паскале которая будет вводить целые числа до 0, подсчитать среднее арифметическое этих чисел

+5
Ответы (1)
  1. 15 ноября, 08:52
    0
    Var a, n, sum: integer;

    begin

    sum:=0;

    n:=0;

    readln (a) ;

    while a0 do

    begin

    sum:=sum+a;

    n:=n+1;

    end;

    writeln (sum/n) ;

    end.
Знаете ответ на вопрос?
Не уверены в ответе?
Правильный ответ на вопрос 👍 «Написать программу в паскале которая будет вводить целые числа до 0, подсчитать среднее арифметическое этих чисел ...» по предмету 📗 Информатика. Развернутая система поиска нашего сайта обязательно приведёт вас к нужной информации. Как вариант - оцените ответы на похожие вопросы. Но если вдруг и это не помогло - задавайте свой вопрос знающим оппонентам, которые быстро дадут на него ответ!
Искать готовые ответы