Задать вопрос
18 мая, 16:36

Первое задание

дано целое двузначное число x. выведите число, полученное при перестановке его цифр. значение x ввести с клавиатуры

второе задание

дано целое трёхзначное число x. составьте программу вычисления суммы и произвидения цифр трёхзначного числа x. значение x ввести с клавиатуры

+5
Ответы (1)
  1. 18 мая, 20:05
    0
    1)

    var x, y:integer;

    begin

    readln (x) ;

    y: = (abs (x) mod 10) * 10 + (abs (x) div 10) ;

    if x<0 then y:=-y;

    writeln (y) ;

    end.

    Пример:

    -25

    -52

    2)

    var x, x1, x2, x3:integer;

    begin

    readln (x) ;

    x:=abs (x) ;

    x1:=x div 100;

    x2:=x div 10 mod 10;

    x3:=x mod 10;

    writeln ('S = ', x1+x2+x3,' P = ', x1*x2*x3) ;

    end.

    Пример:

    271

    S = 10 P = 14
Знаете ответ на вопрос?
Не уверены в ответе?
Правильный ответ на вопрос 👍 «Первое задание дано целое двузначное число x. выведите число, полученное при перестановке его цифр. значение x ввести с клавиатуры второе ...» по предмету 📗 Информатика. Развернутая система поиска нашего сайта обязательно приведёт вас к нужной информации. Как вариант - оцените ответы на похожие вопросы. Но если вдруг и это не помогло - задавайте свой вопрос знающим оппонентам, которые быстро дадут на него ответ!
Искать готовые ответы