Задать вопрос
27 апреля, 04:18

Помогите написать программу на паскале!

Создать файл а4, состоящий из 28 целых чисел. Найти среднее арифметическое всех чисел.

+5
Ответы (1)
  1. 27 апреля, 04:39
    0
    Program abc;

    var f: text; { Если не будет работать, то написать вместо "text" "file of longint" или еще что-нибудь другое.}

    x, y: longint;

    i: byte;

    begin

    y : = 0;

    assign (f, 'a4') ;

    reset (f) ;

    for i : = 1 to 28 do

    begin

    read (f, x) ;

    y : = y + x;

    end;

    writeln (y / 28) ;

    close (f) ;

    end.
Знаете ответ на вопрос?
Не уверены в ответе?
Правильный ответ на вопрос 👍 «Помогите написать программу на паскале! Создать файл а4, состоящий из 28 целых чисел. Найти среднее арифметическое всех чисел. ...» по предмету 📗 Информатика. Развернутая система поиска нашего сайта обязательно приведёт вас к нужной информации. Как вариант - оцените ответы на похожие вопросы. Но если вдруг и это не помогло - задавайте свой вопрос знающим оппонентам, которые быстро дадут на него ответ!
Искать готовые ответы